It is currently Tue Nov 21, 2017 12:58 am

All times are UTC




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Mon Apr 21, 2014 11:27 am 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1119
Location: Central Europe
Damage control update: macOS 10.13 ‘High Sierra’ reportedly broke most wrappers (see post 1, post 2). In short, Cider seems not to work at all; Wineskin requires to disable Auto Detect GPU Info for Direct3D (right-click or ctrl-click on the wrapper, select Show Package Content, launch Wineskin, click on Advanced, then Screen Options –> Other Options), but the wrapper might crash before you can set the option. For Uru: CC the situation might be even worse, as even Wineskin doesn’t seem to work.

Following from my Mac OS X tutorial, in this post I’ll note my experiences in the additional steps required to run the various Shards with the Wineskin wrapper method. The most recent engine versions don’t seem to work as well with MOULa: I use Wineskin 2.6.2 (wrapper) and WS9Wine 1.5.21 (engine), except for The Open Cave shard, which requires the 1.7.18 engine, and the Gehn shard, which requires (at least) the 1.9.2 engine (see below). In my experience the 1.5.21 version is a bit more responsive, at least on older machines. You can get my premade wrappers from here and ignore most of the instructions related to DLLs below.

Again, “pointing the wrapper to” stands for: right-click (ctrl-click) on the wrapper, select Show Package Content, launch Wineskin, click on Advanced, then Browse, select Program Files/(Uru Live/)<exe/msi/bat file> and click on Choose, then on Done, and close the window.

Most shards require a working Uru Live folder, to be copied in the Program Files folder inside the wrapper. A few (Gehn, TOC) can download the data files themselves, but pointing the installer to an existing Uru Live folder will of course take far less time.
Also, in most cases the Visual C++ 2013 libraries are required. vcredist_x86.exe doesn’t work with Wineskin, however, so you’ll need to manually copy the msvcp110.dll, msvcr110.dll, msvcp120.dll and msvcr120.dll DLLs either in the drive_c/windows/system32 folder or directly in the Uru Live folder. If you followed the instructions from my other tutorial, or are using my premade wrappers, you should already have them.

If the wrapper crashed and you can’t relaunch it again, it’s likely that Wine itself got stuck. To close it, launch the Wineskin program inside the wrapper (any wrapper, it makes no difference). Click Advanced > Tools > Kill Wineskin Processes. As the notice will say, this will close every wine process, not just those from the wrapper itself.

Gehn Shard
You can get my premade wrapper here. If it crashes, try running it once with “/image” in the EXE Flags field to patch all the data files.
Gehn.22+ requires the Visual C++ 2015 libraries, which are now supported by the latest versions of Wine(skin). Wrappers are being tested and discussed in the GoW thread.

The following refers to previous versions of the Gehn Shard.
The ‘third method’ in the Mac OS X tutorial is a mostly identical copy of Deledrius’ original post on the GoW; since then, a new installer was made capable of installing this Shard even from scratch. Therefore you can follow Deledrius’ tutorial to the letter, by pointing the wrapper to the Gehn installer, follow its instructions and then pointing the wrapper to UruLauncher.exe.
Starting with Gehn.20, this shard requires the Visual C++ 2013 libraries to run (see above).
If you still get the “UruExplorer.exe has encountered a serious problem and needs to close” error message, you’ll need to use the 1.7.18 engine (you can download it from Wineskin Winery, and update the wrapper with Advanced > Tools > Change Engine Used).

The Open Cave
You can get my premade wrapper here.
This Shard too has now an automated installer, but you’ll need to add the Visual C++ 2013 libraries to run (see above).
Starting from version 2.17, you’ll need the 1.7.18 engine (see the instructions for the Gehn shard). Once you’ve done that, the process is the same as for the Gehn installer. If you’ve already installed the legacy PhysX component, you can skip the PhysX install that might show up.

Minkata
You can get my premade wrapper here.
The instructions found in the link in the email you got when you registered can be followed to the letter.
Alternatively, you can use the Cider wrapper; you'll need to change the server status URL.


H’uru CWE Client and Destiny Shard
You can get my premade wrapper here.
Follow the instructions in AdamJohnso’s post, but point the wrapper directly to plClient.exe and type the “/ServerIni=server_moula.ini /SkipPreload” string in the EXE Flags field.
Once you have this client set up, you could use it for the Destiny testing Shard, if you need it. Or turn it into a Marker Editor client.

Skydiving Client
Follow the instructions in Lyrositor’s post (but use this libeay32.dll instead) and point the wrapper to UruSkydiving.exe.
Alternatively, you can use the Cider wrapper (libeay32.dll is here).

PlClient
You can get my premade wrapper here. If you want to make it yourself, here’s how:
  1. Open (a copy of) the MOULa wrapper and delete everything inside the Uru Live folder except the dat and sfx folders (maybe rename the folder to PlClient918);
  2. Get cwe918_moul-scripts.7z (or cwe918_client.7z), unzip it and copy the Python and SDL folders in the PlClient918 folder;
  3. Get these DLLs and copy them in the PlClient918 folder;
  4. Get the PlClient files (you’ll need to be registered to download it) and copy the whole content in your PlClient918 folder;
  5. Point the wrapper to plClient918c.exe and type “/ServerIni moulagain.ini /localdata” in the EXE Flags field.


Uru: Complete Chronicles
Yes, you can run the offline game, too. If you have the GOG version, it should install fine, with the same procedure as MOULa (point the wrapper one time to the installer, then once it’s done to Uru.exe or UruSetup.exe). Note that the GOG installer put the Uru folder in a GOG Games folder inside drive_c, outside Program Files; you can just leave it there or move it inside Program Files. Here is my premade wrapper; obviously it’s empty, you’ll have to point it to the installer as described.
If you have other versions and have access to a Windows environment (like Bootcamp), you could install it there, then copy the Uru CC folder inside the wrapper.
Also note that there is a serious audio bug in Relto and near Zandi’s trailer, where you hear loud white noise; possible solutions are being discussed here (in short: use engine 1.5.0, either mine or Ainia’s).

[Reveal] Spoiler: Edits
  1. added some links.
  2. made PlClient work. Added Marker Editor link.
  3. added Skydiving with Cider link.
  4. added UruCC audio bug thread link.
  5. specified the Wineskin versions I use.
  6. updated Gehn’s instructions.
  7. updated TOC’s instructions.
  8. TOC and Gehn now need the 1.7.18 engine.
  9. added note about relaunching wine.
  10. moved the Visual C++ 2013 instructions to the top.
  11. added link to my wrapper.
  12. added instructions for GOG’s version of Uru: CC.
  13. added link to an installing tutorial for Uru: CC.
  14. added temporary note regarding Gehn.22 not working with Wine.
  15. updated Wineskin wrappers to version 2.6.2. Some change of wording.
  16. added a tentative Wineskin wrapper for the Gehn Shard.
  17. updated wrapper for the Gehn Shard.
  18. minor expansion of Minkata instructions.
  19. updated links to premade wrappers.
  20. updated notice about wrappers for Gehn.
  21. added my 1.5.0 wrapper for Uru: CC.
  22. added note about macOS High Sierra incompatibility.
  23. updated wrappers links.

_________________
Image
KI #46116 Image Donate to help the Cavern stay open!
MacOS wrappers, D’ni Notes, DniTools, goodies


Last edited by korovev on Thu Nov 02, 2017 1:47 pm, edited 9 times in total.

Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 24, 2016 8:33 pm 
Offline

Joined: Tue Jul 30, 2013 5:05 am
Posts: 8
Currently, when running the Open Cave pre-made wrapper the initial Wine downloads go fine, I can get to the login screen, and even start up the game, but when the game begins its updates I get the following error:

Update Failed: kNetErrorFileNotFound Data\dat\CustomAvatars_District_Bahro1.prp.gz

Is this a file that needs to be copied from elsewhere? Have you seen this issue before?

Possibly related, or not, it looks like the 1.5.21 engine file does not exist anymore on Mediafire.


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 24, 2016 11:20 pm 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1119
Location: Central Europe
If you have a current version of the vanilla MOULa, you could copy that file from the dat folder (Wrapper/drive_c/Program Files/Uru Live/dat).

The weird thing is that for me the TOC premade wrapper no longer work, but my old one does; if you can, please test it.

_________________
Image
KI #46116 Image Donate to help the Cavern stay open!
MacOS wrappers, D’ni Notes, DniTools, goodies


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 25, 2016 2:13 am 
Offline

Joined: Tue Jul 30, 2013 5:05 am
Posts: 8
So far, every time I try to copy one or a group of files from the MOUL game over to the wrapper, it just finds another missing file. Seems like there might be a bunch and there are also a lot of zero k files within the wrapper. It may be possible to make it work by continuing down this path, but it seems like it may take a while.


Top
 Profile  
Reply with quote  
PostPosted: Mon Jan 25, 2016 10:14 am 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1119
Location: Central Europe
You can copy the whole folder :wink:

_________________
Image
KI #46116 Image Donate to help the Cavern stay open!
MacOS wrappers, D’ni Notes, DniTools, goodies


Top
 Profile  
Reply with quote  
PostPosted: Sat Oct 07, 2017 2:59 pm 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
EDIT: ALL FIXED!!
After several restarts of my machine AND logging in to/out of the second user account, these problems have disappeared and everything is working as before. I'll leave this stuff here though in case anyone else has similar problems after upgrading.

--------------------------------------------------------------



Oh dear. :roll: ... here we go again...

After upgrading to High Sierra - and having to adjust the Wineskin Wrappers to get them to work again - we now have the 'High Sierra Supplemental Update' which - guess what - *sigh* - breaks all the Complete Chronicles (tPotS) Shard Wrappers causing Uru.exe to "experience a serious error" during start up.


This update (7th Oct 2017) has broken the wrapper for:
Deep Island Shard
TOC - tPotS Shard
(Offline) Complete Chronicles Game
- plus another CC-based shard that I don't think I'm supposed to tell you about :shock: .

All the MOUL-based Shard Wineskin Wrappers continue to work properly, including:
MystOnline Uru Live,
Ghen Shard,
TOC-MOULa Shard
Minkata Shard

So, basically, if you're playing on a Mac with this new OSX update installed then you can't access any Shard/Game with lots of fan Ages in them.

Please, if you have installed this latest Update and can access any of the CC-based Shards or OffLine CC game, could you please post on here what Wrapper/Engine you are using so I can get back to checking out the new fan Ages.

Many thanks.

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Top
 Profile  
Reply with quote  
PostPosted: Sat Oct 07, 2017 8:52 pm 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1119
Location: Central Europe
I’ve updated the OP with a note about the situation. Unfortunately at the moment that’s all I can do :x .

Note that currently the Wineskin forum is flooded with posts about this issue, so the developer is well aware of it.

Cider I think is no longer actively developed, so if High Sierra broke it, this might be the end of it.

_________________
Image
KI #46116 Image Donate to help the Cavern stay open!
MacOS wrappers, D’ni Notes, DniTools, goodies


Top
 Profile  
Reply with quote  
PostPosted: Mon Oct 30, 2017 10:12 am 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
Hi korovev,
Just to let you know (before you make any new wrappers) that I have Uru:CC working perfectly on my Mac running High Sierra.

Wrapper version: 2.6.2
Engine: WS8Wine1.5.0
Screen Options: nothing selected

This wrapper works very well.
The horrible audio crackling in Relto and The Nexus is 95% reduced (compared to using the 1.5.21 engine) and barely audible.
One proviso: (On my machine) I must start iTunes before running Uru:CC. If I don't have iTunes open (it does not need to be playing any music, just open) then the game stack dumps immediately after playing the two opening bink movies (Ubisoft and then Cyan).
I have no idea why iTunes is needed, I just know it is. I have tested this over and over and can reproduce this "effect" without exception.
What I don't know is if this is specific to my machine (late 2013 iMac with Intel Pro 5 graphics card) or to High Sierra.
I would be very interested to know if this iTunes anomaly also applies to other Mac users.

I also have all the shards running via Wineskin, including MOULa. The wrappers/engines I have working are as follows:

MOULa 2.6.2 / 1.5.21
Deep Island : 2.6.2. / 1.5.0
Ghen: 2.6.2. / 1.9.5
Minkata. 2.6.1. / 1.5.20
TOC -MOUL 2.6.1. / 1.7.20
TOC - tPotS. 2.6.1. / 1.5.0
UAM 2.6.2. / 1.7.2. (Audio OFF- I can not get this Shard to run with audio enabled)

IMPORTANT:
All of these wrappers require iTunes to be running in the background on my machine.
All these wrappers have all the screen options unticked.

I'm sure there are many Mac users who would appreciate your efforts in making "out of the box" wrappers available for High Sierra. I would also like to find a wrapper/engine combination that would let me play UAM with sound if you (or anyone reading this) could find one.

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Last edited by boblishman on Mon Oct 30, 2017 2:30 pm, edited 2 times in total.

Top
 Profile  
Reply with quote  
PostPosted: Mon Oct 30, 2017 2:08 pm 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1119
Location: Central Europe
Hold on, on the weekend I’ll upload wrappers with the engines you listed :lol:
Are you sure you can’t use 2.6.2 for all of them?

Keep in mind though that, for reasons stated elsewhere that I’m not bringing up again, I will not upload a wrapper for the last shard you mentioned.

_________________
Image
KI #46116 Image Donate to help the Cavern stay open!
MacOS wrappers, D’ni Notes, DniTools, goodies


Top
 Profile  
Reply with quote  
PostPosted: Mon Oct 30, 2017 2:25 pm 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
korovev wrote:
Are you sure you can’t use 2.6.2 for all of them?

To be honest, I haven't tried changing the 2.6.1 wrappers, I just changed and/or updated the engines. I'm a great believer in the saying "if it's not broken, don't fix it" ... :lol:

Quote:
"Keep in mind though that, for reasons stated elsewhere that I’m not bringing up again, I will not upload a wrapper for the last shard you mentioned.

I wasn't sure if I should even mention that Shard here :oops:
Would it be best to just remove from the list?

I have also added MOULa to the list (I only just noticed it was missing!!)

I know someone who has been having REAL problems with his MOULa install on his MacBook and I know he will be VERY happy with your news!

Thanks korovev, the community appreciates the work you do for it.

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Top
 Profile  
Reply with quote  
PostPosted: Wed Nov 01, 2017 8:26 pm 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
Just a heads up korovev ... when building new wrappers in High Sierra, make sure that you UNtick all the screen options BEFORE you try and install an executable.
If you don't, you get the "Opps ... no executable found" message.

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Top
 Profile  
Reply with quote  
PostPosted: Thu Nov 02, 2017 7:54 pm 
Offline
Obduction Backer

Joined: Mon Oct 22, 2012 6:07 pm
Posts: 1119
Location: Central Europe
Alright, I’ve updated the wrappers in the OP! A few notes (which at some point I’ll need to add to the readme file):

I’ve used 2.6.2 for all, as that’s the version I have and I’m not aware of a way to downgrade it.

Both MO:ULa and Minkata use Wine 1.5.21, since the latter is meant to be close to Cyan’s version. 1.7.x seems to work too, but in my case they run slower.

Gehn has 1.9.5, TOC has 1.7.20; there is some play with the third number, but those seem to be sweet spot. Occasionally an alert pops ups saying that UruLauncher.exe needs to close, but it’s usually a false alarm. Some other times, when quitting, the wrappers seem to stay open until closed manually (⌘Q).

For the offline game (let’s limit ourselves to that, in this forum ;) ) I used 1.5.0; there are hints that 1.7.x and above could also work, but 1.5.0 seems to be the one that works for most people. Generally speaking, audio seems to be broken in one way or another with whatever version.


@ boblishman: I still have no idea why you need iTunes open, because I never do, and as far as I know other Mac players don’t need it as well. It seems like it’s that particular model (graphic card? I have an Intel HD Graphics 6000) that has that issue. Do you work with music? Maybe you have some audio library that’s interfering?

Also, my copy of Cider works fine :? To change to native resolution, first switch to windowed mode (⌘↵), move the resolution slider (F4) to the right, close the settings then switch to full screen again.

_________________
Image
KI #46116 Image Donate to help the Cavern stay open!
MacOS wrappers, D’ni Notes, DniTools, goodies


Top
 Profile  
Reply with quote  
PostPosted: Thu Nov 02, 2017 8:41 pm 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
I have made a step-by-step guide for anyone wishing to make their own MOULa wrapper.

It is written for the very basic or new Mac user.

I will always keep this up to date so as soon as Apple release an update to MacOS I will immediately update that page. It is currently for making a wrapper for High Sierra 10.13.1

You can find it here

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Top
 Profile  
Reply with quote  
PostPosted: Thu Nov 02, 2017 8:52 pm 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
korovev wrote:

@ boblishman: I still have no idea why you need iTunes open, because I never do, and as far as I know other Mac players don’t need it as well. It seems like it’s that particular model (graphic card? I have an Intel HD Graphics 6000) that has that issue. Do you work with music? Maybe you have some audio library that’s interfering?


It may be to do with SoundFlower which I have installed. It does seem to "hog" the audio at times and I think that, maybe, starting iTunes sorts out some file permissions which Uru needs. Anyway, I can live with it as I do use the Soundflower drivers from time to time.

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Top
 Profile  
Reply with quote  
PostPosted: Fri Nov 03, 2017 1:45 pm 
Offline
Obduction Backer

Joined: Mon Jan 29, 2007 7:01 pm
Posts: 114
Location: Spain
Update: Yes, it was the soundflower app that caused this iTunes behaviour anomaly.
I'm posting this because I've discovered something about this behaviour that might impact on other Mac users.
It seems that when the wrappers are built they somehow reference your audio drivers. Simply uninstalling the app and it's drivers does not "fix" this crashing behaviour. I have found it necessary to build new wrappers AFTER removing soundflower. New wrappers created after the removal of SoundFlower do not need iTunes running. It seems therefore that it's impossible to repair a wrapper that was build whilst these other audio drivers were present on your system. Those internal audio references are not repaired by refreshing the wrapper, changing the engine or anything else withing Wineskin. You have to build a new wrapper AFTER the drivers/app removal.
Anyway, my Shards are now working without iTunes. Phew!

_________________
*** If only I was as clever as I think I ought to be ***

and ...

uʍop ǝpısdn ʇsod uɐɔ l 'sǝʎ

Ki # : 02037973


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: