It is currently Fri Nov 22, 2019 8:59 pm

All times are UTC




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: d3dx9_27.dll is missing
PostPosted: Thu Dec 24, 2015 1:12 am 
Offline
Obduction Backer

Joined: Fri Nov 17, 2006 3:17 am
Posts: 2848
Location: Hilo, I wish...
I have been running Uru without problems for quite a long time, but today I got "Failed to delete old patcher executable. Access is denied." So I ran the patcher as administrator, as recommended. Then I got "The program can't start because d3dx9_27.dll is missing from your computer. Try reinstalling the program to fix this problem." So I reinstalled, and I'm still getting the same message. I've hunted around the forum (not very long, I admit) but I haven't found any information on this problem. Any help would be appreciated. Not urgent. Thanks!

Edit to add: I'm running Windows 7 x64

_________________
Explorer at large

:)


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 24, 2015 1:21 am 
Offline

Joined: Thu Apr 10, 2008 9:32 am
Posts: 621
Location: Southern California
I'm sorry to read you're having a problem with the new build, too.

I'm using Windows 7 64-bit, too, but interestingly, I did not receive any error message regarding that dll. I'm sorry I don't have any advice for you. I think that dll might be related to DirectX.

However, I'm getting a black screen and I posted a thread about it here: viewtopic.php?f=40&t=28146.

_________________
Susa'n KI#1040105 (member Shorah gah bigtotee's Hood)


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 24, 2015 1:43 am 
Offline

Joined: Tue Mar 05, 2013 9:58 pm
Posts: 363
Location: GMT +1
Uru requires a few extra DLLs that aren't included in Windows (anymore). You can get them using this installer from Microsoft. (When downloading, be careful that you uncheck the "offer" to make MSN your homepage and Bing your search engine! You can also ignore all of the other "suggestions" from the list.)
Once you've downloaded the installer, make a new folder on your desktop, run the installer, and tell it to extract into the folder you created. Then run the "DXSETUP.exe" in the folder to install the DLL files. After you've done that, check if Uru runs now. If so, you can delete the folder from your desktop and the installer.

_________________
MOULa2.dgelessus=32253


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 24, 2015 1:51 am 
Offline

Joined: Thu Apr 10, 2008 9:32 am
Posts: 621
Location: Southern California
There is a similar program called DirectX 9.0c End-User Runtime (dxwebsetup.exe), which is available here: http://www.microsoft.com/en-us/download ... g=en&id=35.

_________________
Susa'n KI#1040105 (member Shorah gah bigtotee's Hood)


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 24, 2015 2:03 am 
Offline

Joined: Tue Mar 05, 2013 9:58 pm
Posts: 363
Location: GMT +1
Yes, that works as well if you're on Windows 7 or older. The "end-user" web installer doesn't work anymore on Windows 10 (no idea about 8/8.1), but the redistributable version works on all systems starting with XP. (Also it's a web installer, meaning that it doesn't contain any actual files - it needs to download them from Microsoft first. That is okay if you just want to install it, but useless if you want to keep it as a backup.)

_________________
MOULa2.dgelessus=32253


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 24, 2015 4:04 am 
Offline

Joined: Wed Apr 21, 2010 5:09 am
Posts: 230
Location: Questing...
I had the same problem. A reinstall of the newest directx fixed it.

_________________
KI# 00102019
"Either write something worth reading or do something worth writing." -B. Franklin


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 24, 2015 12:44 pm 
Offline
Obduction Backer

Joined: Fri Oct 05, 2007 7:35 pm
Posts: 28
Location: the Netherlands
Back in cavern!
Thank you dgelessus, your instruction was very helpful.


Top
 Profile  
Reply with quote  
PostPosted: Fri Dec 25, 2015 12:46 am 
Offline

Joined: Wed Dec 23, 2015 5:16 am
Posts: 30
I just wanted to add that I had the problem as well after the update.

I didn't have the benefit of a forum thread so I had to figure it out on my own.

Installing directx enduser runtime as has been suggested is what I did and it worked for me.

I would like to add though that i had to put in the name of this direct x feature in a search engine and follow that link.

The relevant link on microsoft's website redirects to a promotion for windows ten.


Top
 Profile  
Reply with quote  
PostPosted: Thu Dec 31, 2015 12:37 am 
Offline
Obduction Backer

Joined: Fri Nov 17, 2006 3:17 am
Posts: 2848
Location: Hilo, I wish...
Thank you! :)
The DirectX end user update worked for me and now all is back to normal.
Happy New Year!

_________________
Explorer at large

:)


Top
 Profile  
Reply with quote  
PostPosted: Thu Jan 14, 2016 10:12 pm 
Offline

Joined: Thu May 18, 2006 11:08 pm
Posts: 3838
Location: In the Cleft
i had this problem on both my XP system and my new 8.1 system i hope this fix works thanks for the info.

_________________
URU MOUL Lives
Admin
3D World and Game Developers Group Linkedin
"We Build Worlds"


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 17, 2016 3:34 pm 
Offline

Joined: Wed Sep 09, 2015 8:29 pm
Posts: 200
So I just installed Win 10 on my computer, reinstalled MOULa and this problem came up. I installed DirectX and the problem still persists. I also tried installing from one of the other websites Cyan has listed. Not sure where to go from here.

_________________
Image
Ki# 2996132


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 17, 2016 5:38 pm 
Offline

Joined: Tue Mar 05, 2013 9:58 pm
Posts: 363
Location: GMT +1
I assume you installed the redistributable version from one of my previous posts? The web installer always fails immediately with an error message for me on Windows 10. Also can you post the entire error message that you get? You might be missing a different DLL file (perhaps those described here).

_________________
MOULa2.dgelessus=32253


Top
 Profile  
Reply with quote  
PostPosted: Sun Jan 17, 2016 9:53 pm 
Offline

Joined: Wed Sep 09, 2015 8:29 pm
Posts: 200
dgelessus wrote:
I assume you installed the redistributable version from one of my previous posts? The web installer always fails immediately with an error message for me on Windows 10. Also can you post the entire error message that you get? You might be missing a different DLL file (perhaps those described here).


Thank you. That fixed the problem.

_________________
Image
Ki# 2996132


Top
 Profile  
Reply with quote  
PostPosted: Mon Jun 13, 2016 3:36 pm 
Offline

Joined: Fri May 19, 2006 10:30 pm
Posts: 53
Hi all,

had many problems trying to get back in with windows 10.
I was sent this link via FB. It worked a treat.
Hopefully it'll work for others in the same predicament. :)

https://www.microsoft.com/en-us/download/details.aspx?id=35&nowin10

Mat

TMP again, woot!


Top
 Profile  
Reply with quote  
PostPosted: Mon May 22, 2017 8:04 pm 
Offline
Obduction Backer

Joined: Sat Mar 03, 2007 5:47 am
Posts: 127
Location: Buckeye, Arizona
Okay i'm helping Barefoot to get back in.. he has windows10 but he lives in Canada and he cannot download the needed file. I cannot pass that file to him because of its size (95.6mg and i live in AZ).

where can he get this.. i'm not finding anything safe on the internet..

Cennie


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: